Figures: Add and manage images

Note: You can also import a manuscript that includes images, using the File > Import > Content.


Add a single or multi-panel figure

To add a figure panel to your manuscript, first add a figure panel (as a placeholder) and then add an image to the panel. After changing to a multi-figure layout, you can add additional figures to the panel.

  1. Place the text insertion cursor next to the spot where you want to insert the figure.
  2. Insert a figure panel using one of the following methods:
    • By selecting Insert > Figure from the main menu.
    • By clicking the insert figure symbol in the toolbar. Insert Figure
    • By opening the gutter helper insertion menu (the blue + symbol in the left margin) and selecting Figure Panel.

      Selecting any of these options adds a figure panel placeholder, where you can add an image.

      Empty figure panel
  3. If you want to include more than one image in your figure panel:
    1. Open the gutter selection helper menu by clicking the blue o in the left margin.
    2. Select Layout followed by the type of layout you want to use. For example, Layout > Two Figures Side by Side.

      Change figure layout
  4. Add images to your placeholders.
    You can do this in two ways:
    • Dragging and dropping an image onto the + placeholder.
    • Clicking the placeholder to bring up a list of orphaned, or unplaced, images. From here, you can either select one of these images and click Choose, or click Choose File to Import… and navigate to the file you want in Finder.

      List of unplaced figures
      Note: If all figures in your document have been placed in figure panels, you will not see a list of figures, but will be able to drag-and-drop a new image, or choose a file to import.
  5. Define a caption for your figure by clicking the caption placeholder text and typing.

Add or replace a figure within a panel

  1. Click on the image or placeholder.
    This brings up a list of unplaced images, if your manuscript contains any.

    Choose a figure
  2. Select an image by either:
    • Selecting an image from the list and clicking Choose.
    • Dragging an image onto the placeholder, or
    • Clicking Choose File to Import…, navigating to your image, and selecting it.

Remove a figure panel

You can delete a figure panel either from the outline or the gutter helper selection menu.

  • To use the outline, right-click on the figure in the body of the outline (not the list at the end) and select Delete Figure Panel.
  • To use the gutter helper, place the focus on the figure panel, then click the blue o in the left margin and select Delete Figure Panel.

Remove orphaned figures from the figure list

All figures imported, selected, or dragged into your manuscript that are unplaced will appear in the list of choices for a new figure panel. If you want to remove figures from this list:

  1. Click on an image or figure placeholder to bring up the list of unplaced images.
  2. Select the name of the image you want to remove.
  3. Click the down arrow to the far right and select Delete Unplaced Figure.

    Delete unplaced figure

Note Deleting an unplaced image removes it from the manuscript; it does not delete the file from the original location.


Select a figure layout for export

You have several options for how Manuscripts can handle figures when you export your manuscript. Figures can be exported:

  • Inline with the rest of your manuscript, as it appears when you are editing.
  • As a single, separate file that contains all of your figures.
  • With each figure in its own separate file.
  • With the manuscript itself, but placed at the end of the manuscript, rather than inline.

You can also specify for each figure whether it should be exported with the manuscript or as a separate file.

Define how all figures are exported for this manuscript

  1. With the focus somewhere in the body text of the document and not in a table or figure, open the Style tab of the Inspector, to the right.
  2. Under Manuscript, open the Figure Layout dropdown and select the style you want to use.

    Setting the export lyaout style for figures

Define how a single figure is exported

  1. Right-click on the figure in the manuscript outline, or, with the figure in focus, open the gutter helper selection menu.
  2. Select either Exported with Manuscript or Exported as Separate File.

    Setting export options for a single figure

Create a new figure style

Figure styles define the placement and alignment of the figure caption, the style of the outer border of a figure (and whether it has a border at all), as well as the style of the inner border, for multi-panel figures. Manuscripts includes several figure styles by default, for example, Borderless, Caption Below.

You can define your own figure style and apply to multiple figures, using the style tab of the Inspector:

  1. With the focus on a figure, open the Inspector and select the style tab.

    Defining a Figure Style

  2. If you want to define a new style and name it, rather than overwriting the default table style:
    • Select Duplicate from the dropdown menu to make a copy of the currently selected figure style.
    • Select Rename from the dropdown menu and enter a new name for the style.

      Renaming a Figure Style
  3. Customize the figure style:
    • For captions, you can adjust the Placement (above or below the figure) and the Alignment.
    • For borders, you can set the Style, Color, Width, and Spacing.
    • Switch between the outer border (applying to the entire figure panel) and the inner panel (applying to each figure in a multi-figure panel) by clicking the figure panel border tabs.
      Border tabs for Figure Style

Apply a style to a figure

You can apply a figure style by right-clicking on the figure in the outline, or by using the gutter helper selection menu.

To use the gutter helper, first make sure the figure is in focus. Open selection menu (the blue o sign), select Style, then select the name of the figure style you want to apply.

Applying a Figure Style


Set the width for a figure

You can control the width of a figure, in terms of a percentage of the maximum page width, on a figure-by-figure basis. To do so:

  1. With the figure in focus, open the selection menu of the gutter helper, or right-click on the figure in the Outline.
  2. Select Size and choose the maximum percentage you want.

    Setting figure width

Hide or show figure captions

Use the gutter helper selection menu to toggle figure captions on and off. With the table in focus, click the blue o in the left margin to bring up the selection menu, then select Hide Capture or Show Caption.

Toggling figure captions


View a list of all figures

At the bottom of the manuscript outline, below the sections titles, you can view a list of your figures, either as a sequential list or by section. Click a figure caption to jump to the figure location within the manuscript.

List of figures in the outline


Figure file formats

To ensure that images are treated in a non-destructive manner, Manuscripts stores all placed images at full resolution, even if you scale them for presentation within the document. Vector graphics are stored in their original form and are only rasterized as bitmap images upon export, when required.

Some export formats and even some manuscript templates have restrictions on image formats. These specifications are stored with the formats and templates, and Manuscripts handles the image transformations for you, transparently. This saves you from having to worry about which format you need for a given purpose and whether all figures have been handled properly.