Tables: Create tables and insert pre-rendered tables


Insert an empty table

  1. Place your cursor where you want to insert the table.
  2. Insert a table using one of the following methods:
    • Click the table figure in the toolbar. Insert table
    • From the main menu, select Insert > Table.
    • Using the gutter helper insertion menu (the blue + symbol in the left margin) select Insert Table.

      An empty table is added with a default layout that you can customize.
      Inserting a table

  3. Click any header, data, or footer placeholder to enter text.
  4. To add a caption, click the Caption placeholder and add your text.

Customize rows and columns in a table

To customize your table, right-click inside the table to bring up the context-sensitive menu. Depending on where you have placed your cursor, you can add rows and columns before or after your current position, or delete a row or column from the table.

Customizing a table

Alternatively, you can also select Format > Table from the main menu to select the same options.


Create a table style

  1. With the focus on a table, open the Inspector and select the style tab.

    Defining a Table Style

  2. If you want to define a name for the new style, rather than overwriting the default table style:
    • Select Duplicate from the dropdown menu to make a copy of the currently selected table style.
    • Select Rename from the dropdown menu and enter a new name for the style.

      Renaming a Table Style
  3. Customize the table style:
    • To set the caption, adjust the Show Caption and Alignment settings.
    • To style the line separators, click on a line to select it, then set the Style, Width, and Color settings at the bottom.
    • Click inside a row, or Option-Click inside a column, to select it, then set the Background and Alternate Color settings on the bottom.

Apply a table style

You can apply a table style by right-clicking on the table in the outline or by using the gutter helper selection menu.

To use the gutter helper, first make sure the table is in focus. Open selection menu (the blue o sign), select Style, then select the name of the table style you want to apply.

Applying a Table Style


Show or hide table headers, footers, and captions

Use the gutter helper selection menu to toggle table headers, footers, and captions on and off. With the table in focus, click the blue o in the left margin to bring up the selection menu, then choose the hide or show option.

Toggling table elements


Insert a pre-rendered table

You can add a table that has been created in another app, such as Numbers or MS Excel, to your manuscript. The table displays as a preview and is not editable. However, you can add and control the caption as you would with any other table. To insert a pre-rendered table:

  1. Place the text insertion point where you want to insert the table. The table will be placed after the current paragraph.
  2. From the main menu, select Insert > Pre-rendered Table.
    This inserts a placeholder for the table. Note that it says Click to choose image because through this process, you will be inserting a static image of the existing table.

    Placeholder for a Pre-rendered Table
  3. Click the placeholder, then either drag the file from Finder into the import popup, or click Choose File to Import… to select from Finder.
    One inserted, the table is shown using its image preview. When you export your manuscript, the fully-rendered table will be included in the export.

    Pre-rendered Table

  4. Click Caption placeholder to define a table caption.

View a list of all tables

At the bottom of the manuscript outline, below Figures, you can view a list of your tables. Click a table name to jump to the table location in the manuscript.

List of tables in the outline


Delete a table

To delete a table, either:

  • Right-click on the table in the outline and select Delete Table, or
  • With the focus on the table, open the gutter helper selection menu (the blue o symbol) and select Delete Table.

    Deleting a table

Select the table layout for export

As with figures, you have several options for how Manuscripts handles tables when you export your manuscript. Tables can be exported:

  • Inline with the rest of your manuscript, as it appears when you are editing.
  • As a single, separate file that contains all of your tables.
  • With each table in its own separate file.
  • With the manuscript itself, but placed at the end of the manuscript, rather than inline.

You can also specify for each table whether it should be exported with the manuscript or as a separate file.

Define how all tables are exported for this manuscript

  1. With the focus somewhere in the body text of the document and not in a table or figure, open the style tab of the Inspector, to the right.

    Setting the export lyaout style for tables

Define how a single table is exported

  1. Right-click on the figure in the manuscript outline, or, with the figure in focus, open the gutter helper selection menu.
  2. Select either Exported with Manuscript or Exported as Separate File.

    Setting export options for a single figure